SSL Certificate

Incident Report for Cavo

Resolved

The Cavo ssl cert has been updated.
Posted Mar 29, 2021 - 09:47 CDT

Investigating

Our Cavo SSL Certificate expired this morning. We are updating it now.
Posted Mar 29, 2021 - 09:26 CDT
This incident affected: CAVO Application - Production and CAVO Application - Beta.